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Microsoft Excel 2007
Objectives
· Understand the use of spreadsheets and Excel

· Learn the parts of the Excel window

· Scroll through a worksheet and navigate between worksheets

· Create and save a workbook file

· Enter text, numbers, and dates into a worksheet

· Resize, insert, and remove columns and rows

· Select and move cell ranges

· Insert formulas and functions

· Insert, delete, move, and rename worksheets

· Work with editing tools

· Preview and print a workbook

Introducing Excel
· Microsoft Office Excel 2007 (or Excel) is a computer program used to enter, analyze, and present quantitative data

· A spreadsheet is a collection of text and numbers laid out in a rectangular grid.

· Often used in business for budgeting, inventory management, and decision making

· What-if analysis lets you change one or more values in a spreadsheet and then assess the effect those changes have on the calculated values

Exploring Excel
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Feature Description

Office Button A button that provides access to workbook-level features and program settings

Quick Access Toolbar A collection of buttons that provide one-click access to commonly used commands, such as Save, Undo,
and Repeat

Title bar A bar that displays the name of the active workbook and the Excel program name

Ribbon The main set of commands organized by task into tabs and groups

Column headings The letters that appear along the top of the worksheet window to identify the different columns in the
worksheet

Workbook window A window that displays an Excel workbook

Vertical scroll bar A scroll bar used to scroll vertically through the workbook window

Horizontal scroll bar A scroll bar used to scroll horizontally through the workbook window

Zoom controls Controls for magnifying and shrinking the content displayed in the active workbook window

View shortcuts Buttons used to change how the worksheet content is displayed—Normal, Page Layout, or Page Break
Preview view

Sheet tabs Tabs that display the names of the worksheets in the workbook

Sheet tab scrolling Buttons to scroll the list of sheet tabs in the workbook

buttons

Row headings The numbers that appear along the left of the worksheet window to identify the different rows in the
worksheet

Select All button A button used to select all of the cells in the active worksheet

Active cell The cell currently selected in the active worksheet

Name box A box that displays the cell reference of the active cell

Formula bar A bar that displays the value or formula entered in the active cell





Navigating a Worksheet
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Entering Text, Numbers, and Dates in Cells
· The formula bar displays the content of the active cell

· Text data is a combination of letters, numbers, and some symbols

· Number data is any numerical value that can be used in a mathematical calculation

· Date and time data are commonly recognized formats for date and time values

Entering Multiple Lines of Text Within a Cell
· Click the cell in which you want to enter the text

· Type the first line of text

· For each additional line of text, press the Alt+Enter keys (that is, hold down the Alt key as you press the Enter key), and then type the text
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Changing Column Width and Row Height
· A pixel is a single point on a computer monitor or printout

· The default column width is 8.38 standard-sized characters

· Row heights are expressed in points or pixels, where a point is 1⁄72 of an inch

· Autofitting eliminates any empty space by matching the column to the width of its longest cell entry or the row to the height of its tallest cell entry

Changing the Column Width and Row Height
· Drag the right border of the column heading left to decrease the column width or right to increase the column width

· Drag the bottom border of the row heading up to decrease the row height or down to increase the row height

or
· Double-click the right border of a column heading or the bottom border of a row heading to AutoFit the column or row to the cell contents (or select one or more column or rows, click the Home tab on the Ribbon, click the Format button in the Cells group, and then click AutoFit Column Width or AutoFit Row Height)

or
· Select one or more columns or rows

· Click the Home tab on the Ribbon, click the Format button in the Cells group, and then click Column Width or Row Height

· Enter the column width or row height you want, and then click the OK button

Inserting a Column or Row
· Select the column(s) or row(s) where you want to insert the new column(s) or row(s); Excel will insert the same number of columns or rows as you select

· In the Cells group on the Home tab, click the Insert button (or right-click a column or row heading or selected column and row headings, and then click Insert on the shortcut menu)

Inserting a Column or Row
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Deleting and Clearing a Row or Column
· Clearing data from a worksheet removes the data but leaves the blank cells

· Deleting data from the worksheet removes both the data and the cells

Working with Cells and Cell Ranges
· A group of cells is called a cell range or range 

· An adjacent range is a single rectangular block of cells

· A nonadjacent range consists of two or more distinct adjacent ranges

· A range reference indicates the location and size of a cell range

Selecting Cell Ranges
To select an adjacent range:
· Click the cell in the upper-left corner of the adjacent range, drag the pointer to the cell in the lower-right corner of the adjacent range, and then release the mouse button

or
· Click the cell in the upper-left corner of the adjacent range, press the Shift key as you click the cell in the lower-right corner of the adjacent range, and then release the Shift key

To select a nonadjacent range of cells:
· Select a cell or an adjacent range, press the Ctrl key as you select each additional cell or adjacent range, and then release the Ctrl key

To select all the cells in a worksheet:
· Click the Select All button located at the intersection of the row and column headings (or press the Ctrl+A keys)

Selecting Cell Ranges
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Moving or Copying a Cell or Range
· Select the cell or range you want to move or copy

· Move the mouse pointer over the border of the selection until the pointer changes shape

· To move the range, click the border and drag the selection to a new location (or, to copy the range, hold down the Ctrl key and drag the selection to a new location)

or
· Select the cell or range you want to move or copy

· In the Clipboard group on the Home tab, click the Cut button or the Copy button (or right-click the selection, and then click Cut or Copy on the shortcut menu)

· Select the cell or upper-left cell of the range where you want to move or copy the content

· In the Clipboard group, click the Paste button (or right-click the selection, and then click Paste on the shortcut menu)

Inserting and Deleting a Cell Range
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Inserting or Deleting a Cell Range
· Select a range that matches the range you want to insert or delete

· In the Cells group on the Home tab, click the Insert button or the Delete button

or
· Select the range that matches the range you want to insert or delete

· In the Cells group, click the Insert button arrow and then click the Insert Cells button or click the Delete button arrow and then click the Delete Cells command (or right-click the selected range, and then click Insert or Delete on the shortcut menu)

· Click the option button for the direction in which you want to shift the cells, columns, or rows

· Click the OK button

Entering a Formula
· A formula is an expression that returns a value

· A formula is written using operators that combine different values, returning a single value that is then displayed in the cell

· The most commonly used operators are arithmetic operators 

· The order of precedence is a set of predefined rules used to determine the sequence in which operators are applied in a calculation
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Entering a Formula
· Click the cell in which you want the formula results to appear

· Type = and an expression that calculates a value using cell references and arithmetic operators

· Press the Enter key or press the Tab key to complete the formula
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Copying and Pasting Formulas

· With formulas, however, Excel adjusts the formula’s cell references to reflect the new location of the formula in the worksheet
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Introducing Functions
· A function is a named operation that returns a value

· For example, to add the values in the range A1:A10, you could enter the following long formula:


=A1+A2+A3+A4+A5+A6+A7+A8+A9+A10

 
Or, you could use the SUM function to accomplish the same thing:


=SUM(A1:A10)
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Entering Functions with AutoSum
· The AutoSum button quickly inserts Excel functions that summarize all the values in a column or row using a single statistic

· Sum of the values in the column or row

· Average value in the column or row

· Total count of numeric values in the column or row

· Minimum value in the column or row

· Maximum value in the column or row
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Inserting and Deleting a Worksheet
· To insert a new worksheet into the workbook, right-click a sheet tab, click Insert on the shortcut menu, select a sheet type, and then click the OK button

· You can delete a worksheet from a workbook in two ways:

· You can right-click the sheet tab of the worksheet you want to delete, and then click Delete on the shortcut menu

· You can also click the Delete button arrow in the Cells group on the Home tab, and then click Delete Sheet

Renaming a Worksheet
· To rename a worksheet, you double-click the sheet tab to select the sheet name, type a new name for the sheet, and then press the Enter key

· Sheet names cannot exceed 31 characters in length, including blank spaces

· The width of the sheet tab adjusts to the length of the name you enter

Moving and Copying a Worksheet
· You can change the placement of the worksheets in a workbook

· To reposition a worksheet, you click and drag the sheet tab to a new location relative to other worksheets in the workbook

· To copy a worksheet, just press the Ctrl key as you drag and drop the sheet tab

Editing Your Work
· To edit the cell contents, you can work in editing mode 

· You can enter editing mode in several ways:

· double-clicking the cell

· selecting the cell and pressing the F2 key

· selecting the cell and clicking anywhere within the formula bar
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Using Find and Replace
· You can use the Find command to locate numbers and text in the workbook and the Replace command to overwrite them

[image: image17.png]_ ve 1 Fimd amdl Replace dlalog bos

Find and Replace

X
search value L3} [replaces the

i current occurrence
| Find | Replace |
replace value |_ of the search value
-|F>r_|d what > [ave. ¥ [MoFormatset | [_Format... -
i te s (@ Replace Wit | Avenue ] [NoFormatset | [ Formet... < highlights all

the current sheet

Within? | Sheet V| [Omateh case OCCur':enc]es of the
[ Match entire cell contents search value

replaces all Lookin: [Formlas Options << ||_ Grds the next
occurrences of occurrence of the
the search value ] i i R e e ioer search value

Search: |By Rows





Using the Spelling Checker
· The spelling checker verifies the words in the active worksheet against the program’s dictionary
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Changing Worksheet Views
· You can view a worksheet in three ways: 

· Normal view simply shows the contents of the worksheet

· Page Layout view shows how the worksheet will appear on the page or pages sent to the printer

· Page Break Preview displays the location of the different page breaks within the worksheet
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Working with Portrait and Landscape Orientation
· In portrait orientation, the page is taller than it is wide

· In landscape orientation, the page is wider than it is tall

· By default, Excel displays pages in portrait orientation

To change the page orientation:

· Click the Page Layout tab on the Ribbon

· In the Page Setup group, click the Orientation button, and then click Landscape 

· The page orientation switches to landscape

Printing the Workbook
· You can print the contents of your workbook by using the Print command on the Office Button

· The Print command provides three options:

· You can open the Print dialog box from which you can specify the printer settings, including which printer to use, which worksheets to include in the printout, and the number of copies to print

· You can perform a Quick Print using the print options currently set in the Print dialog box

· Finally, you can preview the workbook before you send it to the printer

Viewing and Printing Worksheet Formulas
· You can view the formulas in a workbook by switching to formula view, a view of the workbook contents that displays formulas instead of the resulting values

· To change the worksheet to formula view, press the Ctrl+` keys

· Scaling a printout reduces the width and the height of the printout to fit the number of pages you specify by shrinking the text size as needed
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